Failed to work for firewall behind network

Jan 30, 2012 at 9:46 AM

I have tried Terminal services powershell module. But it fails for me. My machines are behind the firewall and has no LDAP username.

I verified whether the port 445 is opened or not. Port 445 is opened. But still i am getting issues.  ( This is the command i have used to verified it

"(new-object Net.Sockets.TcpClient).Connect($host, $port)" .

Coordinator
Feb 2, 2012 at 9:54 AM

Just to clarify, there's a firewall in between, firewall allows port 445 traffic and the command fails? What errors do you get?

May 22, 2014 at 11:26 AM
Edited May 22, 2014 at 11:27 AM
Bringing up an old thread i know, but stumbled across this troubleshooting an issue i'm having.
the module doesn't work behind a firewall. 445 is open.

when if i run the following

$users = Get-TSSession -ComputerName $server
echo $users.count

If the server is behind a firewall then it always returns 0. If its a server not behind a firewall, then returns the correct value.